Transcend Consent supports the following minimum browser versions:

  • Chrome 93+
  • Edge 93+
  • Brave 1.30+
  • Firefox 91+
  • Firefox ESR 91+
  • Safari 12.1+

We may update browser requirements in the future and update this list accordingly